Jailbreaking ZIM after Zeepro stopped it´s services?

Hey guys!
Back in the days when zeepro was still a company to deal with, they offered to jailbreak your ZIM. It was just a process of registering your ZIM with it´s serial number and giving up the guarantees of the device.
I had a few issues in the beginning that could be solved with pierre´s help so I thought it might not be a good idea to give up my guarantee and support.
But now, I gained some experience in 3D Printing and regarding the fact that I most likely will never ever get any information about my last issue from Zeepro´s support, I wonder if it was still possible to jailbreak the device.
(I have already tried the way that Zeepro offered, but since the server is down, this won´t work)

Any suggestions how to do that?
(I don´t want to move away from the current software, due it is easy to use and prints most of my parts quite okay, but I also want to have the possibility to run my own G-code if it is necessary)

1 Like

Use a RaspBerry Pi and forget about jailbreaking your Zim: it’s like riding on a dead horse… :wink:


1 Like

Okay… could be fun, either. :stuck_out_tongue_closed_eyes:

I´ll have look at your link, thanks!

Today I fired up my raspberry Pi with Octoprint. Works perfectly!
Just beacause I was not familiar with the steps, here’s how to do it:

  • Load “Arduino IDE” software and the Firmware 1.0.16, modified by jpod. The links to that data can be found in the thread ‘Octopie Tutorial’
  • Install Arduino and run it as Administrator.
  • connect the zimboard to your PC using the USB port
  • open jpod’s firmware, compile it and copy it to the zimboard.
  • search for the youtube video http://youtu.be/oa5vwvJ2eY4 and follow the steps.
  • be happy

Ok Guys, I have got the same problem and after serching I found a way to “jailbreak” the ZIM

As the Zeepro servers seems to be down you cannot register the ZIM and cannot access the Zim interface. (locked on the register page)
I started searching and found that you need to remove a file on the SDCARD. You need to get a software to be able to read the ext2 file format (Linux file format) get into the folder conf located on the root of the sdcard and remove the NeedActive.tmp file
Plug back the sdcard in the machine and power on.

That’s all falks ^^


Hm… I´m thinking about… Erm…
No… I won´t go back to Zeepro´s software :wink: Not after I managed to print with Octoprint.

But thanks a lot for finding out!

Yes it was as simple as this. I thaught I would spend lot of time and finally it was really easy. I am happy, I can use the ZIM.
In the future I may also shift on octoprint. :smiley:

But for the other side it is fun to keep the machine as genuine as possible :heart_eyes:

I am looking to manufacture the nozzle as it have been developped :smile:

Thank you for this “jailbreak” solution.
My ZIM is now set apart waiting for the usb port to be replaced but my desoldering skills seems to be very low :sweat_smile:
Maybe the “jailbreak” could be an alternative solution to upload g-code from S3D. Did your solution give you access to the g-code uploading page on ZIM?

The solution to delete one certain file on the SD-Card to use the “third party G-Code upload feature” in the original ZIM Software was discovered by @Nightmare. I however, haven´t tested this solution, because I had already switched to Octorint on Raspberry when he came up with it.
I´m sure he can help you

@J_Schmidt Thanks for your reply. I finally had the usb port replaced with some cold sweat and a wire bridge :sweat_smile:.
Thank to this forum my ZIM is now working with Simplify3D! This is awesome!

ZIM is a really fine piece of Hardware. It is exremely robust and rigid compared to the wooden boxes (although they are also way better than they appear), and it offers a great design.
Most of the disadvantages of the machine have already been solved in this forum, or at least are being processed.

So you use Simplify3D? I haven´t tried it because of the lack of a free trial version. I for myself use Slic3r and Octoprint because of the stand-alone features, others use Cura… Once you seperate the easy-to-understand but limited ZIM-software from the Hardware, you can control ZIM with whatever you want. THAT is was open source means.
JPOD did a great job in modifying the firmware, so ZIM is handeled like a normal Marlin based Printer. It´s a bit sad that the guys from Zeepro ended this project so inglorious. The company really had the potential for more.

I agree, even if ZIM is my first 3Dprinter, so I can not really compare with others, the results look pretty good. For exemple the 3D Benchy test came out really nicely. Zeepro may have failed in some commercial ways and in the open source approach ; ) but the ZIM is a great 3D printer and it is really nice that it continues being developed through this forum.

I just made my first test with Simplify3D, the result looks good with smooth surfaces. The top layer failed for this first print but it certainly needs some other settings. The software view and control panels are very user friendly. But overall the support structures are super easy to remove with very low impact on the surface. If you want to compare with Slic3r, you can send me a 3Dfile you want to test, and I’ll send you back the Gcode and screen captures…

Here is how to root your zim:

  1. Connect a serial cable to your Zim Cubie board. Video

  2. Connect to the serial port with the zeepro unpowered.

    In my case I use: sudo cu -l /dev/cu.usbserial -s 115200

  3. Power up then hit the enter key when you see “Hit any key to stop autoboot: 0 1 …”

  4. Type setenv init /bin/bash and press enter.

  5. Type boot and press enter.

    The cubieboard will boot up and log you in as root. Once you see the root@(none):/#, you are logged in but the root drive is read only.

  6. Type mount -o remount,rw / and hit enter to make the root file system writable.

  7. Now you want to set the root password. Just type passwd root and you will be prompted to enter a new password. Enter the same password twice to set it.

  8. Now just remount the root file system in read only mode for good measure with mount -o remount,ro /

  9. Now you just need to power cycle your zeepro so it will boot up fully.

That is all there is to it. After you have the root password set, you can do anything you want to the embedded linux system including installing octoprint. Once you figure out you network ip address for your zim, you can ssh into it with ssh root@your_ip_address.

The Zim cubieboard is running “Debian GNU/Linux 7.1”.


It would be easier if we had the original root password. Here is the default root hash if anyone has a GPU cluster they want to run against it:



Interesting thing about the SDRAM on the cubieboard. The memory controller on the a10 only supports 1GB but the board actually has 8GB onboard (2x SK hynix H5TQ4G63AFR). They must have been cheap at the time of manufacture. Also interesting is that the processor is reportedly capable of booting from USB0 If you hold down the power button while booting.

On the PCB you can see A10 but in fact the CPU is a A20 ^^

I also found a other amazing hack.
If you want to download the Zeepro Slic3r presets. you save them under a other name and you will find them stored on the SD card.
the SDcard is EXT format. you go to /conf/presetlist/
you find folders. inside each folder you have a slic3r preset. The preset.json files has the name of the preset and the config.ini is the slic3r file

If you have rooted the cubieboard the original files are located

@Nightmare cool! Are those different than the ones @mtbf0 posted here? Upload G-code (work around) If so can you upload them somewhere or send them to me and I’ll host them?

If you don’t have a serial cable I posted a rooted version of 1.8.4 over on the backup firmware thread. The image is actually here.

@Nightmare I can confirm the cpu is indeed an a20 and both cores are online.

root@zim:~$ cat /sys/devices/system/cpu/cpu*/online