New firmware broke my Zim!

#1

DO NOT ERASE YOUR ORIGINAL SD CARD THAT CAME WITH THE ZIM!
You will need the original SD.

Tools needed

  • Phillips screw driver

  • A micro-SD card (4 Go are enough) – Warning: all content will be lost

Important note: YOUR NETWORK CONFIGURATION WILL BE LOST

You’ll have to re-connect your printer to your network, please be sure to have all needed information at hand.

MAKE SURE THE PRINTER IS SWITCHED OFF

  1. Remove the internal cover behind the cartridges by unscrewing the screws:

  2. Locate the onboard micro-SIM reader situated on the PC board (left side of the printer):

  3. Remove the inserted micro-SIM by pushing it gently in its slot (I’m going to call this one the original)
    Keep it safe as you’ll need to reinsert it later. DO NOT FORMAT IT!!!

  4. Prepare the master micro-SD (This is your blank SD cart that you provided)

Unpack the image file with your favorite archive manager (or download one here: http://www.7-zip.org/download.html)

(be careful, all data will be erased on the micro-SD card) (This is the Micro SD card that you provided)

  1. Insert the master micro-SD card (The one you just formatted)

  2. Switch on the printer

  • the green led will lit continuously for about 40 seconds

  • then the blue led will flash twice every second during 6 and a half minutes

  • and eventually, both blue and green led will lit continuously when the operation is complete

  1. Final instructions
  • SWITCH-OFF THE PRINTER
  • remove the master micro-SD
  • insert the previously mounted micro-SD (This is the one that originally came with the Zim)
  • replace the cover and the fixation screws

Your printer is now updated, please restart its network configuration by following this procedure:
https://zeeproks.freshdesk.com/solution/categories/5000041972/folders/5000065573/articles/5000050243-how-to-connect-zim-to

I copied the above instructions from here minus the pictures and added some notes: http://zimsupport.zeepro.com/support/solutions/articles/5000478058-how-to-re-flash-zim-firmware

Original post:
Has anyone else had problems with the new firmware? I rebooted my zim hoping to get the new firmware so I could see the extruder paths and my Zim never came back from the reboot. I get a green light behind the power button but I get a “404 - Not Found” error using either zim/ or the IP address when I try to access it.

I sent Zeepro an email asking about it and will post if I get a response in case others have this problem.

Update did not change firmware version
So I bought a brand new Zim Dual and
#2

Looks like a connectivity problem.

If I were you, I will reintialize network parameters .

http://zimsupport.zeepro.com/support/solutions/articles/5000059317-how-to-reset-zim-network-parameter-

#3

I would double check your zim IP in your router. Unless you have it set as static, it may have changed when you rebooted.

#4

Tired resetting the network parameters this morning and no luck. Still can’t access the zim.

Awesome you are correct it did change IP addresses when it rebooted but even with the new IP address it still doesn’t work. I just keep getting a 404 error.

Any other idea’s to try? I’m still waiting on Zeepro to get back to me.

#5

Did you try to connect Zim directly with an ethernet wire ? You will know if it is a WiFi problem or not.

#6

I’ve had mine lose the WiFi config and go back to the default 10.0.0.1 ip in access point mode. This happens almost every time I upgrade it, so I’ve come to expect it. I just reconnect to the zim initialization network on 10.0.0.1 and redo the network config. On this upgrade I had to connect via that IP, and then explicitly reset the network via the menus to get that configuration dialog box to pop up.

#7

After pushing the reset again I got the wifi to come up. However its broken. I can connect to the wifi but when I put in the 10.0.0.1 IP address it gives me the zeepro symbol up at the top in the tab but the page says 404-Not Found. I tried both google chrome and internet explorer and neither works :frowning:

#8

You might try forcing a new firmware upgrade. Flash an sdcard image from the support site, insert it, then boot and let it reflash the NAND. I have done this a couple of times when the Zim appeared unresponsive. Could be the file system became corrupted? I’m not sure. I remember I completely wigged mine out one time by messing with reprogramming RFID cartridge settings, and this “fixed” it.

#9

Thanks, Just got a email from Zeepro and re installing the firmware was there suggestion as well. I will try that probably tomorrow when I get a chance.

Update: Either the microSD card or the download was bad. I redownloaded it and used a different microSD card and it flashed the firmware without a problem.

#10

I had the same issue a while back I had to reflash the firmware on the sd card. REMEMBER TO DO THIS YOU NEED THE ORIGINAL SD AND A NEW ONE AS WELL. And dont trust the solutions on the Zeepro page there are errors in the instructions so if it just doesnt seem to work It may not be you.

#11

My Zim is dead after the last update to 1.7.

Could you please elaborate on the correct process to recover the Zim?
The “How to re-flash zim firmware” is somehow wrong or missing important information.
And there is a parallel article with the same topic that I followed first and erased the original sd card, that I seem to need and is now lost.

Right now I did download the empty image and reflashed the sd card, reinserted this card and turned on the Zim.
After 30 minutes the blue led is still blinking and I dont now what to do.

#12

You are probably going to have to contact Zeepro if you formatted your original SD card. I read somewhere that the original card is keyed to the serial number on the zim so they have to send you a new image to flash.

I will update my first post with better directions to try and help people who have this problem.

#13

The SD cards are not keyed to the machine. I delayed on updating from version 1.3 to 1.6 until last week. When I did the update my machine crashed. I followed the instructions off the support website, and on one new SD card installed the firmware to flash the cubbie board. On another new SD card I installed the “empty” image file. The original 4gb card that came with the machine I will likely format to clean up whatever is corrupt on it and use it in something else. You can follow the links on the support page for both of these file sets.

#14

Zeepro support sent me the newest firmware. Quick reply, thats great.

But when I try the article of the support website “how to re-flash zim firmware” my Zim never stops blinking blue after inserting the sd card with the empty image.

Is this different with your Zims? Or am I doing something wrong here?

#15

I had a similar problem with my zim but it kept flashing blue with the firmware update card in it. I ended up readownloading the firmware and using a different micro SD card. Maybe try a different micro sd card?

Slappyj where did you find the download for the blank micro SD card image? I will update my first post with the link for others.

#16

There are two concurring articles on this and in one of them there is the link to the empty sd card image:
https://zeeproks.freshdesk.com/support/solutions/articles/5000523650-how-to-re-flash-zim-micro-sd-card
In the other article is the latest firmware sd card image:
https://zeeproks.freshdesk.com/support/articles/5000478058-how-to-re-flash-zim-firmware

Having these two articles with different images and different instructions is not helping.
There needs to be one article on how to get your Zim running again after Update Failure with correct instructions.
If I ever find out how to reactivate my Zim I will at least try to post my solution here.

#17

Ok, my Zim is back in business.

Now I understand what to do in what order.

Here is what I did:

  1. if you accidentally overwrite your original SD card you can recover the SD card with this guide:
    https://zeeproks.freshdesk.com/support/solutions/articles/5000523650-how-to-re-flash-zim-micro-sd-card
    In it you have the empty SD card image that is supposed to be the original SD card.
  2. for installing the latest firmware go with this guide:
    https://zeeproks.freshdesk.com/support/articles/5000478058-how-to-re-flash-zim-firmware
    In it you have the latest firmware that has to go to the temporary other SD card.

Power off the Zim and remove the original SD card.
Than insert the firmware SD card first and poer Zim on and wait for the led to stop blinking blue. It took 15 minutes with my Zim.
Power off the Zim and insert the original SD card and power on the Zim.

  1. You have to reinitialize the Network Setup.

And you are done.
Hope this helps other Zim users some trouble and time.

#18

Yep, I’ve been there, and done that… a couple of times :slight_smile: So far never had it in a state it wasn’t recoverable by flashing the right image from the support website. I once even modded the file system and loaded that up as an experiment (you can mount the sdcard image under Linux and look at/modify the file system). It just blinked blue forever until I reloaded a stock image. It appears there is more going on during firmware upload than just copying the file system across to NAND… some sort of MD5 sum or some other validation perhaps.

#19

Sorry to hear about these troubles… for a datapoint, I just finally repaired my Zim (had to replace the main large ribbon cable that runs from the zimboard to the printhead, and clear a bunch of broken pieces of PLA from the teflon tube) and firmware was at 1.3. I restarted my Zim and it upgraded all by itself to 1.7.1 and kept it’s Wi-Fi settings.

After leveling I printed out the second best part ever tonight, the shocked emoji from zeepro models. Very round and very clean. It was also my first time using blue painters tape. I have to say it makes the first layer stick great and fairly easy to pop the piece loose by peeling up the tape. My first best part was just as nice finish wise, just much larger than this one… so more of a success :wink:

#20

Really Really Really need firmware 1.8.4