Great! I read everything...Bought a PI. Paid for someone to solder a new USB and still cant print

Dear Friends,

Bfore someone says “go read the read the forum”…I´ve most of it. My USB por was dead…Now its working. I´ve bought a PI and tried my best to follow the instruction…Frustration took over since i recently moved and theres not a SINGLE usd to USB cable on this bloody house…Moving on…After reading everything and since clearly patience is not one of my virtues. I need someone to please just answer a simple question:

-> Can i use the Zim, connected directly via USB to the computer (not using RPI, or Octopi), and SIMPLIFY 3D?

Honestly i have everything (hardware) but im interested im spending my time designing and printing objects. The set up for me must be basic. To my understanding there is no need to use a PI if you dont want a camera, or a wifi connection to the printer. I removed the A10 Board since i guess is not needed for USB connection with this setup. So, why the hell cant i seem to be able to extrude anything from each nozzle after heating them up to 250C (PLA)?

What is the extruder speed you gyus are using:

Is there any known problem with SIMPLIFY3d Direct USB connection?

Thanks and sorry but i spent the WHOLE afternoon dismounting ZIM, and mounting ZIM, and 6 hours later i Still cant print anything…

Ive never used simplify3d, so i cant speak to its connectivity.

But if you are onnecting to the printer, and able to heat it up. It may just be an issue with that, your nozzle is clogged (if you hear the stepper trying to extrude and it just isnt thats the most likely thing)

Simplify3D works great.
If you are able to connect, move the head and printbed around and heat up, but only extrusion does not work, it could be a clogged nozzle, you are using the wrong tool, some hardware error like bad connection or damaged board or most likely a wrong configuration.
If you use a wrong speed setting it simply sounds strange or bad, but works.

In other threads all there is to know and much more has been discussed, posted and even complete configuration files have been published. There are a lot of nice people taking the time to publish their results, tutorials and even corrected firmwares. So please take the time to read the other threads.

Here are my manual settings:

Bear in mind that these are the manual speed settings that are different from those you configured for actual printing.

Thanks. O think i know what happened (its easier after sleeping)…i left filament on both heads and did not work with the printer for quite some time…After recovering the USB port firt thing i tried to do was unload the filament…and the speed of the stepper on the head by default was huge! When i pressed extrude or retract the first time the cog that pulls/pushes the filament probably destroyd the filament and now its impossible to push/pull. Ill try to unclog both nozzles later and let you guys know the result.

Just one question, i’ve noticed that on S3D tool 1 heats up but when you press extrude on that tool you see the opposite stepper working…is this “normal”?

Thank you so much.

Tool 0 is my right nozzle and Tool 1 is my left nozzle.
For the Active Toolhead heating and jog controls control the same Tool components.
Don’t know what you mean by opposite.

The left stepper drives the right extruder, which is Tool 0.
The right stepper drives the left extruder, which is Tool 1.

I always get breaks in my filament because of the small diameter of the cartridges, and will be converting to not use these in the near future. I know it’s a pain, but I really don’t think there can truly be a Consumer 3D printer… at least not one that’s any good. I was new to 3D printing before the Zim, so it sounded great to me… but now I understand the complexity of these systems and respect it :smile: Hope you work out your issues!

Just some things to note, not saying any of this is a problem you are having. As far as builds sticking to the plate and leveling… I haven’t changed it in 6 months and have the same blue tape on my print bed… prints keep popping out like magic. I use the Zim white and black PLA at 200C, and try to extract filament at 220C. If you ever have to change the filament, I would advise just throwing away the length that already has teeth marks on it from extracting since it’s liable to break the next time you feed it in. When extracting it’s liable to get kinked up inside the cartridge as well since there’s not spring return or anything inside of there… it just pushes it back in and hopefully it spools up. I see it jam on extraction as well so I watch when it comes out of the extruder, stop the extraction process and then just pull the cartridge out and pull the filament out of the teflon tube manually. Then you can just cut that piece off.

Hi there

This shouldnt be an issue. I quit cartridges long time ago. I have direct feed to the head.
As per consumer grade…lolol. But then again i dont think that anyone here thought that would be possible even with Zim. I just want to have thr hardware up and running 4 or 5 profiles and i should be good to go! To tell the truth i really enjoy simplify3D interface a lot more than Zeepro…
That will be my next request for help. People sharing their proven to be working fine s3d profiles…

Thanks m8 is hard to keep up on this setups…most skilled backers already have some sort of stable solution and im trying to keep up but its hard! First time i sawna raspberry was when i bought one yesterday! :wink:

Thanks again!

Yes it’s normal. The stepper on left drives the right extruder and vice versa.

Btw, I really love the design of my MakerGear M2 direct feed to the extruder. It is similar to what many of us have done with the Zim, the major difference being they don’t bother to lock the teflon tube into the extruder. This allows really quick filament changeover, as you only have to retract about 100mm to get the filament out of the extruder, and then extrude 100mm to get the new filament going. It literally takes seconds to change out filament. I’ve done some multi-color prints by simply inserting a pause in the gcode at a given layer (as shown by simplify 3d), swapping the filament, and then unpausing octoprint and away it goes with the new color. This is something we should think about doing on the Zim as well. There is really no reason to lock the tube into the extruder the way they did it, that I can see.

1 Like

First things first! The steppers are fine! :wink:
Attempting first print! Calibrating the bed on S3D was a total pain…Lets see how it goes…

Ok…so I managed to heat up the extruder but…its prints for 10 minutes or so and all of the sudden the temperacture starts to drop and print fails. This is happening on Simplifyd with USB direct connection. Any tips on this? I´ve searched the fórum na tried to add some code to the before printing starts…with no luck…

Thanks in advance.

Ok. So extruder heats up to the desired temperatures:

Then right after the draft is printed /dont know if its important or if it was pure chance…The temperture starts droping for aparently no reason:

Can any give me a heads up here? This looks clearly software (config) related but i dont know how to fix it. I´ve read some guys had similar problems but with Octopi…tried some of the codes withno luck. Im on stock. No A10, no rasperry, original ZIM, connected to PC using USB cable…

Your help will be much appreciated.

Thanks in advance.

An this post is starting to look like my personal blog…Ok! Ill keep posting my findings! This might b useful for others noobs like me…
Im finally printing. And i think i found what was causing the temperature drop…And that was a bloody setting on S3D parameter where you say you want a set point for cooling…Pretty much what was happening was right after the printer started printing (after 1st layer), the extruder fan on the left kicked in and with it, im guessing the thermostat that sets the extruder head temperature was receiving lots of cool air that was giving a wrong temperature reading to the heater…
Now this is theory…But tried several times with the left fan working with no luck…After shuting off th left fan…it is working! No in Physics this is called cause effect. Dont know if on 3d Printing the principle is the same…But it should be! :smile:)

That the print does not start after temperature is reached and countdown is 0, is a problem a few people have.
After the countdown the printer simply shuts down heating is is kind of finished, without ever reaching a real print finish end.
Why some have it and some don’t I would really like to know.
So far I have not found a solution.

I have tried many things with no change at all.
It is not related to Simplify3D, as the same happens with octoprint or Repetier.
And as we all use the same firmware, it cannot be that neither.

What I do to compensate this problem is hit the Emergency Stop button in Simplify3D. That does a reset of the printer and connection. Next hit print again and the print starts.

Your finding of the cooling setting is probably just coincidence. Sometimes it works right away and a few prints later the problem again. I was not able to replicate the problem. Its pure coincidence.
My left fan does not start. The left fan is only for cooling the print object. So normally it is used for bridging, overhangs and things like that. If it starts right away with 100% you have to look into your settings again. I am pretty sure you have layer 0 with fan 100% there. It was default with me as well.
I would watch out with cooling. More than 60% cools the nozzle down more than it can heat so that you end up with a drop in temeprature until a clog.

But please find the cause. This problem really sucks.

“Me” finding someting when it comes to 3d Printing will be quite an achivement… :smile: As an Engineer for me things only “operate the same way every thingle time” Or “they never operate”. Randoness do not exist on my vocabulary! :smile:
Well my 3d prints up till now never fail to start. The problem was a sudden temperature drop, that happened precisely when the left fan kicked in. This might be a coincidence sure, but its one hell of a coincidence! This afternoon i tried more that 15 times a print that would start only later to stop suddenly due to temperature drop…Parameter changed and im half way my second print and it did not stop yet…
Im sure you will be there to coment when i update with a post saying “this bloody thing is no longer working again”…

Cheers! Let me play with this while it lasts…

IMPRESSIVE!! Never had this detail with my zim before!

There are two causes for unexpected temperature drop in Marlin firmware. The first is inactivity of the steppers. This can occur with a long temperature ramp, such as an m109 to 220c. If it takes longer than 5 mins, the print will cancel and the temperature will drop unexpectedly. Your m84 s0 should eliminate this timeout. This ramp time is printer dependent. I have two, and one extruder on one of them consistently takes just over 5 mins to reach 200C for example. Enabling the fan will exacerbate the problem unless you tweak your PID values.

The second cause is an excessive temperature differential between the command temperature and the actual temperature. I believe a difference of something like 20c will cause an automatic shutdown (if have to look in the code again for the exact value, but it’s pretty extreme). I’ve only seen this in the code, but never experienced it. Again, using the fan at 100% will likely cause the problem. You should never use a fan over 50% on the Zim unless you know how it affects extruder temperature and compensate accordingly. I’ve adjusted my PID values on my printer to account for the fan and speed up stabilization of the temperature. This is an easy procedure. See my previous post on PID adjustment for details of my fan findings.

By the way, my right stepper drives my right extruder nozzle and vice versa.
Interesting that there is a difference in Zim printers.
I wonder if I have a newer or older setup than you.

And fantastic looking print result. I never achieved that smooth and detail.
What profile did you use and could you share the model? I would like to try for reference.

Hi there,
Follow the link bellow for the obj and the profile:

Zoomed in picture:

Probably was already mentioned…I saw something about it on the octopi tutorial…BUT if you connect to the printer directly by USB like i do…DONT FORGET TO DISABLE power saving…It will…Kill…Your PRINTS…Nice!